Flashing a custom VBF, Erasing Blocks failed

Testing new functions
Post Reply
marcgr
Posts: 2
Joined: Sat Aug 21, 2021 12:42 pm
Vehicle: Focus Mk3 2.0tdci 140hp, 2013

Flashing a custom VBF, Erasing Blocks failed

Post by marcgr »

Hello! I'm trying to flash a custom .vbf on my IPC to replace a few images on my Focus MK3.
The file (BM5T-14C026-CV) has 2 data blocks, and the replaced images are in the 2nd block, which had it's length and checksum modified

I'm doing a complete software update with the files recommended by FORScan (except the -CV one which I modified, but the original -CV was still recommended)
When trying to flash to the IPC, using FORScan 2.4.3 test20210808, the SBL and the first Strategy file flash without problems, but the modified one gets stuck when trying to erase memory, getting error "Erasing Blocks Failed"

In the header I see there's only one entry for which area to delete, and it's length seems correct for the first block (data length + checksum), but there are 2 blocks and no mention to delete the second one
What could be the problem here? Maybe a checksum reject?

I've attached below images with the differences between the original and the modified file.


EDIT:
It seems that the original VBF won't flash either for the same reason, so I guess it's a problem with the file?
Attachments
header of original and modified file
header of original and modified file
main.PNG (333.52 KiB) Viewed 373 times
difference between block1 and block2
difference between block1 and block2
block2.PNG (119.87 KiB) Viewed 373 times
von_watchmaker
Posts: 1
Joined: Sun Aug 29, 2021 9:33 am
Vehicle: Ford Focus 2008

Re: Flashing a custom VBF, Erasing Blocks failed

Post by von_watchmaker »

marcgr,
I have a similar problem and I think that it is related not to the change you to the VBF, but the Forscan itself.

When I attempt to flash TCU (LR3T-14G087-VG) with a 'To program' set to Custom and the JL3T-14G139-CS VBF from this site: https://www.fordtechservice.dealerconne ... rogram.asp
I get 'Erasing Blocks failed' error.

The 'Test run SBL' runs fine.
Options 'Force program unchanged firmware' and 'Stop activity on buses' do not change anything.

I am running Forscan 2.4.4 with paid Extended license combined with original OBDLink EX adapter flashed to the newest firmware (5.6.19).
The car is Mustang 2019.
gaz2613
Posts: 23
Joined: Sat Oct 23, 2021 8:05 pm
Vehicle: Ford Focus MK3 1.5 TDCI 2017

Re: Flashing a custom VBF, Erasing Blocks failed

Post by gaz2613 »

To work around this issue. After flashing the first strategy file and it fails at erasing blocks, you will see the first file flashed successfully. Reflash again but this time select custom and select the files manually skipping the first one that you already flashed. It will then complete successfully.
Post Reply