HELP ON CLUSTER REPLACE

Any issues related to FORScan application
Post Reply
Juan1972
Posts: 2
Joined: Thu Jun 30, 2022 5:14 am
Vehicle: F150, 6 CIL, 1/2 TON, 2006

HELP ON CLUSTER REPLACE

Post by Juan1972 »

Hi, I'm new on this. Having issues with Instrument cluster on a 2006 f150 ( similar to a 2002 f150 ).
I replaced cluster but with the "new one" it won't start.
I saw this video on youtube... https://youtu.be/zaKNGJVDFvg?list=PLxoU ... B8a5Wtsndi
but when I do the forscan connection, it reads all the information, but when selecting "module configuration" it doesn't show any information.
I bought the extended license but still no difference.
Any idea of what am I doing wrong?
thanks!
tractmec
Posts: 1001
Joined: Thu May 26, 2016 11:43 pm
Vehicle: F150 5.4 Triton 2005 Expy5.4 2003 Fusion 3.0 2010

Re: HELP ON CLUSTER REPLACE

Post by tractmec »

Juan1972 wrote:
Thu Jun 30, 2022 5:23 am
Hi, I'm new on this. Having issues with Instrument cluster on a 2006 f150 ( similar to a 2002 f150 ).
I replaced cluster but with the "new one" it won't start.
I saw this video on youtube... https://youtu.be/zaKNGJVDFvg?list=PLxoU ... B8a5Wtsndi
but when I do the forscan connection, it reads all the information, but when selecting "module configuration" it doesn't show any information.
I bought the extended license but still no difference.
Any idea of what am I doing wrong?
thanks!
First: Did you match the IPC part numbers as close as possible to the last two characters? The first set must match exactly! Ex. if 5L34-10849-BB is original then any thing with a Bx in the suffix character should cross Ex. 5L34-10849-BC or BA should work(This was my experience with my 2005 F150)! I also found that the Model years 2004 to 2008 on all the lower trim levels are all similar enough to cross Part numbers! This may not be true on higher trim levels and high trim levels will likely not cross to lower trim levels(see Below)!

In that video you posted this change was from the base cluster on a 2005 XL(No Tach, probably minimal display features such as no Outside Temp or compass) To the XLT cluster which has those features! His AsBuilt figures in the Original were totally different to mine and the replacement Cluster AsBuilt was one character different to mine! Also My XLT replacement (BB to BC) cluster had a different third character in the first set and that character was not changeable in either cluster. You could write the third Character C to an E in FORScan but the change would not be written to the AsBuilt(C verses E in the original, however the change to the original IPC AsBuilt configuration was otherwise successful ex 720-01-01-AEC3-000-00-BA)!

Second: make sure you are not connecting using a saved profile(with the replacement IPC installed). Either delete all profiles for this vehicle from Profile Tab with the "Trash Can" Icon or Export the Profiles with the Save icon (looks like a floppy disc) and then delete them! and then reconnect with the replacement installed! This will force FORScan to fully read all the module configurations.

Third: are you opening Module configuration or Module Configuration (AsBuilt)? If you see nothing in IPC module configuration at all(Either Configuration Configuration AsBuilt), something is wrong with that replacement cluster as there should be at least The AsBuilt Configuration with one configurable line with a 720-01 address!

Fourth: hopefully you are not trying to replace one of the lower trim IPC's (XL XLT) with a high trim level (Heritage or Harley Davidson) trim level IPC! The PATS Control for the keys in these trim levels was in the IPC and the lower trim levels was in the PCM and the two will not work together!

If your Red Anti Theft light is on the Dash up close to the windshield then the PCM controls PATS and if it is flashing rapidly or continuously on steady when you turn on the Ignition with the replacement IPC installed, you have PATS problem which should not be happening with a lower trim IPC at all as the the IPC has nothing to do with PATS in the XL or XLT trim levels! This could be the likely cause of your no start condition!

This may or may not be your problem and it would have been helpful if you had posted the reason for this change(Brake warning or restraints warning lights on continuously gauge needles not working or giving erroneous readings, display not working etc! These were common malfunctions in those model year Clusters (reason I replaced mine)!

Edit to Add: If you are doing this replacement on a Higher trim(Anti Theft light would be in the IPC) then you will have to run the FORScan PATS IPC service process in order to delete the keys in the IPC and then Program in your Original keys.

Hope this Helps?
Do not PM me as I am not an Admin nor am I a member of the FORScan Team and all questions should be asked and answered on the Open Forum so all can benefit!
Juan1972
Posts: 2
Joined: Thu Jun 30, 2022 5:14 am
Vehicle: F150, 6 CIL, 1/2 TON, 2006

Re: HELP ON CLUSTER REPLACE

Post by Juan1972 »

Hi, thanks for so very detailed information. Still have the same issue.
But I think that the forscan program is not working with full functions. It just shows a few options. That`s why I bought the extended licence but it shows me the same, need to solve this first.
My issue started when my cluster had some backlights burned, I replaced them with leds, mount back cluster and now the side gauges are not working, just the speedmeter works fine, dont know how this happened since this is not the first time that I replaced burned lights in other clusters.
Then I bought a second cluster, it looks exactly the same, but my truck it won`t start with this 2nd cluster.
Don Ridley
Posts: 689
Joined: Sun Apr 01, 2018 2:31 am
Vehicle: 2016 Transit Connect

Re: HELP ON CLUSTER REPLACE

Post by Don Ridley »

You said:
"It reads all the information"

Does Forscan locate all the modules, especially the IC module? If not, you have an adapter problem.

You can be sure your extended license is active by clicking on the steering wheel/question mark icon. It should say "Extended license registered to:Xxxxx
tractmec
Posts: 1001
Joined: Thu May 26, 2016 11:43 pm
Vehicle: F150 5.4 Triton 2005 Expy5.4 2003 Fusion 3.0 2010

Re: HELP ON CLUSTER REPLACE

Post by tractmec »

Don Ridley wrote:
Wed Jul 06, 2022 7:11 pm
You said:
"It reads all the information"

Does Forscan locate all the modules, especially the IC module? If not, you have an adapter problem.

You can be sure your extended license is active by clicking on the steering wheel/question mark icon. It should say "Extended license registered to:Xxxxx
Juan1972 wrote:
Mon Jul 04, 2022 3:33 am
Hi, thanks for so very detailed information. Still have the same issue.
But I think that the forscan program is not working with full functions. It just shows a few options. That`s why I bought the extended licence but it shows me the same, need to solve this first.
My issue started when my cluster had some backlights burned, I replaced them with leds, mount back cluster and now the side gauges are not working, just the speedmeter works fine, dont know how this happened since this is not the first time that I replaced burned lights in other clusters.
Then I bought a second cluster, it looks exactly the same, but my truck it won`t start with this 2nd cluster.
Don R raises a good point!

FORscan can only read what Modules the truck has and it would have been helpful to include some screen shots of what is actually showing in your module tab tree(easily done with the Windows Snipping tool)!

I have attached a screen of what my 2005 F150 has in its tree and yours should be the same as 2004 to 2006 are interchangeable Part numbers depending on whether you have a Base cluster (No tach and no temp and compass message center) or Family carrier option (Tach and LCD display with outside ambient temp and compass)! Also attached a screen of the IPC configuration and the AsBuilt Configuration!! if the IPC is not showing up in this tab then something is causing it to not report to FORScan!

There will be one exception that depends on the Adapter you are using! The UBP (Uart Based Protocol) will not be read by FORScan unless you are using a Ford VCM 2 or a J2534 Passthru adapter that has UBP capability! FTDI/ELM327 based adapters cannot read this network! This network was in use up to about mid 2008 in the F series trucks!

The License is only needed to run any of the Configuration and PATS programming service procedure! It has no restriction on the module read or DTC clearing or any module tests!


Hope this helps?
Attachments
2005IPC AsBuilt Configuration.PNG
2005IPC AsBuilt Configuration.PNG (58.64 KiB) Viewed 564 times
2005F150IPC Configuration NonAsBuilt.PNG
2005F150IPC Configuration NonAsBuilt.PNG (60.89 KiB) Viewed 564 times
2005F150Moduletree.PNG
2005F150Moduletree.PNG (62.99 KiB) Viewed 564 times
Do not PM me as I am not an Admin nor am I a member of the FORScan Team and all questions should be asked and answered on the Open Forum so all can benefit!
Post Reply